Recognizes in F-Layout & not F-Capture -

Why does my document recognize in FlexiLayout but not FlexiCapture?

FlexiLayout Studio and FlexiCapture use different settings on their OCR engines so, occasionally, recognition results can differ. Ones to watch out for:
  • Very short static text elements.
    One letter wrong on a 3 character string would require an error margin of 34%, the default is 20%.
  • Are you finding the element you think you are?
    You might be finding an element near the bottom of the page when you expect it to be at the top, for instance the company name or a VAT number. Related elements then may be missed when they were, for instance, Below: theElementFoundInTheWrongPlace.Bottom;
  • Are you trying to match a date?
    There might be a wrong character, the date format may be mDy / dMy so ABBYY doesn’t recognise it as a valid date. Consider using a FirstFound to seek a character string if the date doesn’t match. Labelled fields are guilty of this simplification but can easily be converted to a group and then tweaked to include the FirstFound as the Field element.
  • Are you trying to match a character string using a regular expression?
    The regular expression may be too rigid. Consider being less specific about, for example, NNNAAAAA (3 digits, 5 upper case letters) and instead XXXAAAAA (3 digit/letters followed, 5 upper case letters).
This is a problem where FlexiLayout Studio saves information about the documents whilst they are pre-recognized and matched. Ensure that you attempt to match a clean copy of the documents before deploying. This can be done by:
  1. Right Click on the documents in FlexiLayout studio
  2. Select “Delete Page Data"
  3. Then tick all the option in the pop up window
  4. Once the data is cleared, re-match the document.
This is show you if the document has any issue that may arise in FlexiCapture. The next step is to disable all of the search elements and match the document, re-enabling elements each time until you find the issue.
Eg. Musgrave had this issue with a few of their invoices. Worked perfectly in FlexiLayout, but didnt recognize in FlexiCapture. Was unable to find the issue by clearing the data in Layout, but by disabling the element and exporting each time into capture, it was found that a number of my elements not recognizing correctly. Repaired by;
  1. Disabling all elements and blocks
  2. exporting the AFL
  3. re-recognizing the document
  4. rinse and repeat until the problem was found
  5. fixed issue
  6. re-enabled elements and blocks